Minimum System/Software Requirements to run VLC

OS: Windows, Mac, Linux

Browser: Google Chrome® (recommended), Mozilla™ Firefox® 17 or later, Opera™ 11 or later, Safari® 5.0 or later

UPDATE: We no longer provide support for IE-- as it is being phased out by Microsoft, students and professors will continue to have issues on our website and in our courseware using Internet Explorer. As noted above, we highly recommend using Google Chrome or Firefox for best results. 

Audio source (recommended): headphones, speakers

Screen Resolution: 1024 pixels by 768 pixels or greater

Other software needed:

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk